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Using SAAM II Working with Tables 

 

Working with Tables 
Prerequisites 
 

The prerequisite for this tutorial is having worked through the SAAM II 
introductory tutorial, “Getting Started with SAAM II Compartmental.” 

 
What you will learn in this tutorial 
 
The purpose of this tutorial is to show you how to use Tables to export information from 
SAAM II to other applications. You will learn 
 

• How to export information to a plotting application (Part 1) 
• How to export the residuals and weighted residuals (Part 2) 

 
Files Required 
 

Study Files: The study file for this tutorial is 
 

study_0.stu 
 

This file is included as part of this tutorial. This file is the same as study_0.stu 
that is installed in the SAAM II program folder and referred to in the SAAM II 
User Guide. 
 

Introduction 
 
This tutorial focuses on how to use tables that can be created by SAAM II. Many users 
want to post-process results from SAAM II. This can include using other graphics 
packages or statistical packages.   
 
Exporting information from SAAM II to a spreadsheet is also illustrated in this tutorial. 
 
It should be pointed out that, while this tutorial will focus on tables created by SAAM II 
in the Tables window, SAAM II generates other tables of output that can be exported to a 
spreadsheet. For example, the results in the Statistics window following a Fit can be 
exported to a spreadsheet following the same set of rules illustrated in this tutorial for 
information in a Tables window. 
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Part 1. Exporting data for plotting 
 
Suppose one desires to provide a customized plot of an associated sample(s) and data. 
Information to construct a plot can be created in a Table following a Solve or Fit and 
exported to a graphics application. The Tables window’s controls are similar to the Plot 
window’s controls. They are found in the Set menu in Plot/Table Variables and 
Plot/Table Scale. In Plot/Table Variables, you choose the variables you want to appear 
in your table. In Plot/Table Scale, you set the scale (length of time or time interval) of 
your table. 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental 
main window will open. 

 
2. Open the SAAM II Compartmental study file study_0. 

 
a. In the File menu, click Open. The file study_0.stu should appear in the file 

list; if it does not, find the folder where you put this tutorial. Open the study 
file. 
 

b. In the File menu, click Open. The SAAM II Compartmental main window 
will appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 
Experiment. The model of the experiment will appear on the Drawing Canvas 
as follows: 

 

 
 

This is the experimental model developed and used in the Getting Started with 
Compartmental tutorial.  

 
4. Solve the model and view the solution. 
 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II 

Toolbar, click Solve . 
 
b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected. 

 
c. Click s1:plasma to move this to the Current Selection pane. The Plot and 

Tables Variables dialog box will appear as follows: 
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d. Click Done. Your plot will appear as shown below (in linear mode): 
 

 
 

Leave the Plot window open. 
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 Leaving the Plot window open. During your modeling exercise, you can leave 
the Plot window open and perform operations such as changing parameter 
values, solving and fitting. As soon as you change a characteristic of your 
model such as changing the value of the parameter, the solution will disappear 
from your plot. As soon as you Solve or Fit, the updated solution will 
reappear. 

 
 

5. Fit the model to your data. In the Compute menu, click Fit, or alternatively, on 

the SAAM II Toolbar click Fit . Since the Plot window was open during the 
“Fit”, the Plot window will be updated as shown below: 

 

 
 

If you wish to see the plot in semilog mode, in the View menu, click Semilog. 
The plot will change from linear to semilog as shown below: 
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 Linear and semilog plots. To switch back and forth between linear and 
semilog plots, in the View menu, locate Semilog. If Semilog is checked, the 
plot is semi-logarithmic. If Semilog is not checked, the plot is linear. To 
switch back and forth, you need to go to the View menu, and select or cancel 
the Semilog option. 

 
 
 Close the Plot window.  
 
6. View the results in tabular form. 
 

a. In the Show menu, click Table, or alternatively, on the SAAM II Toolbar, 

click Table . Since the Plot window was previously opened with a plot of 
s1 and plasma, the Table window will open as follows: 
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 Generating tables. The table contains the model calculated values at the times 
at which there are data, and at times at which there are “calculation points”. 
The “calculation points” are determined by the Minimum Number of 
Calculation Intervals. This is a mechanism in SAAM II by which the user can 
control the number of values for samples that are saved for plotting and 
tabular purposes. Some plotting packages may require more sample 
calculations. This can be achieved by increasing the Minimum Number of 
Calculation Intervals. 

 
 
b. In the Compute menu, click Computational Settings. The Computational 

Settings dialog box will open. 
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c. Change the Min. Nr. of Calculation Intervals from “20” to “200”. The 

Computational Settings dialog box will appear as follows: 
 

 
 
d. Click Done. The Table window will appear as follows: 
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 Changing a computational setting. When you change a computational setting 
in the Computational Settings dialog box, this will change the characteristics 
of the current solution. In this case, the Minimum Number of Calculation 
Intervals has been increased. The reason why there are no values for s1 is that 
the computational settings have changed. The Table window can be updated 
with a Solve or a Fit. 

 
 
e. Re-Solve the model. The Table window will appear (in part) as follows: 
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Now there are many more values for s1 that have been saved in tabular form. 
This is because of the increase in the minimum number of calculation 
intervals. 
 
You can copy and paste the contents of the table into a plotting application. 
Alternatively, you can copy the contents into a spreadsheet as illustrated 
below. 
 
Leave the Table window open. 

 
7. Export the contents of the Table window to an Excel® spreadsheet. 

 
a. Select and copy the information in the Table window. In the Edit menu click 

Select All.  Then, in the Edit menu, click Copy. 
 
b. Open Excel®. 
 
c. Click the A-1 cell; then on the Edit menu, click Paste.  
 
d. On the Data menu, click Text to Columns …. 
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e. In the Original Data Type pane, select Delimited. The Convert Text to 
Column Wizard – Step 1 of 3 dialog box will appear as follows: 

 

 
 
f. Click Next. 
 
g. In the Delimiters pane, select Space. The Convert Text to Column Wizard 

– Step 2 of 3 dialog box will appear as follows: 
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h. Click Next. 
 
i. Click Finish. The Excel® spreadsheet will appear in part as follows: 
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The data are in columns B, C and D. If you delete column A and left-justify 
the entries in the other columns, the Excel® spreadsheet will appear in part as 
follows: 
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j. SAAM II calculates two values at the end of the experiment. If you scroll 

through the Excel® spreadsheet, you will find two entries for day 9. You can 
delete the entry at day 9 that does not have the datum associated with it. 
 

You can save the Excel® file if you wish. It has been saved and provided as part of this 
tutorial as PlotExcel. 
 
You can now use this file in Excel® or in other software applications. 

 
Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 2. Exporting residuals or weighted residuals 
 
Suppose one wants to use a statistical package to test for goodness-of-fit by performing 
the runs test.  Information on the residuals or weighted residuals can be created in a 
Table following a Fit, and exported directly to a statistical application or a spreadsheet. 
This part of the tutorial will show how to export the weighted residuals to a spreadsheet. 
 

1. Start the SAAM II Compartmental application and open the SAAM II 
Compartmental study file study_0. 

 
2. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas 
as follows: 

 

 
 

This is the experimental model developed and used in the Getting Started with 
Compartmental tutorial.  

 
3. Fit the model and view the solution. 
 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar 

click Fit .  

 Fit without a Solve. You can proceed immediately to Fit without first Solving. 
The reason is that solving in an integral part of the fitting process.  

  
  
b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected. 

 
c. Click s1:plasma to move this to the Current Selection pane. The Plot and 

Tables Variables dialog box will appear as follows: 
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d. Click Done. Your plot will appear as shown below (in linear mode): 
 

 
 

If you wish to see the plot in semilog mode, in the View menu, click Semilog. 
The plot will change from linear to semilog as shown below: 
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 Linear and semilog plots. To switch back and forth between linear and 
semilog plots, in the View menu, locate Semilog. If Semilog is checked, the 
plot is semi-logarithmic. If Semilog is not checked, the plot is linear. To 
switch back and forth, you need to go to the View menu, and select or cancel 
the Semilog option. 

 
 
 Leave the Plot window open.  
 

 Leaving the Plot window open. During your modeling exercise, you can leave 
the Plot window open and perform operations such as changing parameter 
values, solving and fitting. As soon as you change a characteristic of your 
model such as changing the value of the parameter, the solution will disappear 
from your plot. As soon as you Solve or Fit, the updated solution will 
reappear. 

 
 
4. View the weighted residuals. 
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a. In the Set menu, click Plot/Table Variables. The Plot and Table Variables 
dialog box will open. 

 
b. Check the List All Variables check box in the lower left corner of the dialog 

box. 
 
c. Click s1_wres to move this variable to the Current Selection pane. 
 
d. Click Done. In the View menu, click Semilog to change the plot to linear 

mode. The plot of the weighted residuals in linear form will appear as follows: 
 

 
 

d. Close the Plot window. 
 
5. View the results in tabular form. 
 

a. In the Show menu, click Table, or alternatively, on the SAAM II Toolbar, 

click Table . Since the Plot window was open with a plot of s1_wres, the 
Table window will open as follows: 
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 Generating tables. The table contains the model calculated values at the times 
at which there are data, and at times at which there are “calculation points”. 
The “calculation points” are determined by the Minimum Number of 
Calculation Intervals. This is a mechanism in SAAM II by which the user can 
control the number of values for samples that can be saved for plotting and 
tabular purposes. The “runs test” needs calculated values at only the times 
where there is data. This can be achieved by decreasing the Minimum Number 
of Calculation Intervals to 1. 

 
 
b. In the Compute menu, click Computational Settings. The Computational 

Settings dialog box will open. 
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c. Change the Min. Nr. of Calculation Intervals from “20” to “1”. The 
Computational Settings dialog box will appear as follows: 

 

 
 
d. Click Done. The Table window will appear as follows: 
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 Changing a computational setting. When you change a computational setting 
in the Computational Settings dialog box, this will change the characteristics 
of the current solution. Note that all the calculated values s1_wres are no 
longer available as the computational settings have changed. The Table 
window can be updated with a Fit. 

 
 
e. Re-Fit the model. The Table window will appear as follows: 
 

 
 

Rev. 11/01/05 TableUS-21 2002 - 2005 University of Washington 



Using SAAM II Working with Tables 

This contains the desired residuals except for the zero time point which can be 
eliminated. SAAM II calculates two values at the final time of the experiment. 
The duplicate value at day 9 with no residual can also be eliminated. 
 
You can copy and paste the contents of the table into a plotting application. 
Alternatively, you can copy the contents into a spreadsheet as illustrated 
below. 
 
Leave the Table window open. 

 
6. Export the contents of the Table window to an Excel® spreadsheet. 

a. Select and copy the information in the Table window. . In the Edit menu click 
Select All.  Then, in the Edit Menu, click Copy. 

 
b. Open Excel®. 
 
c. Click the A-1 cell; then on the Edit menu, click Paste.  
 
d. On the Data menu, click Text to Columns …. 
 
e. In the Original Data Type pane, select Delimited. The Convert Text to 

Column Wizard – Step 1 of 3 dialog box will appear as follows: 
 

 
 
f. Click Next. 
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g. In the Delimiters pane, select Space. The Convert Text to Column Wizard 
– Step 2 of 3 dialog box will appear as follows: 

 

 
 
h. Click Next. 
 
i. Click Finish. The Excel® spreadsheet will appear in part as follows: 
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The data are in columns B and C. The “########” are numbers whose format 
will not fit into the particular cell. When the number format is reset, they will 
appear.  
 

j. Change the spreadsheet. 
 

(1) Delete column A. 
 
(2) Left-justify the entries in the columns. 
 
(3) Delete the time zero line, and the time 9 line that has no data. 
 
(4) Change the number format to two-decimal places. The Excel® 

spreadsheet will appear as follows: 
 

 
 

You can save the Excel® file is you wish. It has been saved and provided as part of this 
tutorial as WresExcel. 

 
You can now use this file in Excel® or in other software applications. 

 
Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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