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Using SAAM II Working with Experimental Inputs 

 
Working with Experimental Inputs 

 
Prerequisites 
 

The prerequisite for this tutorial is having worked through the SAAM II 
introductory tutorial, “Getting Started with SAAM II Compartmental.” 

 
What you will learn in this tutorial 
 
The purpose of this tutorial is to show you how to specify different input formats for your 
experiment in SAAM II. You will learn 
 

• How to specify the amount of your input in a data file (Part 1) 
• How to specify the amount of the input as an adjustable parameter (Part 2) 
• How to specify split inputs (an input into more than one compartment (Part 3) 
• How to perform parametric deconvolution (Part 4) 

 
Files Required 
 

Study Files: The study files for this tutorial are 
 

study_0_ExpInp.stu 
study_0.stu 

 
These files are included as part of this tutorial. The file study_0_ExpInp.stu is 
the same as study_0.stu that is installed in the SAAM II program folder and 
referred to in the SAAM II User Guide with the exception there are no data in the 
Data window and the parameters have been set to “fixed.” 
 
Remember study_0 is a study file for an experiment lasting 9 days. In this 
tutorial, the time of the experiment may be adjusted so specific points can be 
illustrated. 
 
Data Files:  The data files for this tutorial are 
 

paradecon_ExptInp 
study_0.dat 
 
 
 

Rev. 10/30/05 ExpInpUS-1 2002 - 2005 University of Washington 



Using SAAM II Working with Experimental Inputs 

Introduction 
 
This tutorial focuses on how to use the options in the Exogenous Input dialog box to 
specify less common or more advanced types of input dosage and to conduct parametric 
deconvolution. 
The tutorial covers 
 

• Specifying the amount of a dose as a constant in the data file. 
• Specifying the dose as an adjustable parameter. 
• Split inputs (an input into more than one compartment) 
• Parametric deconvolution 

 
The most frequently used types of dosage inputs are covered in the tutorial 
Experimental Inputs, Basic.  These input types are the bolus, the constant infusion 
and the primed constant infusion and are predefined. The equation input allows the 
user to specify any input as long as the terms of the equation are recognized by 
SAAM II.  
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Part 1. Specifying the amount of an input from the Data window 
 
You can specify information about dosing from the data window. To do so, you use the 
equation input option in the Exogenous Input dialog box. This part of the tutorial will 
illustrate how to specify the amount of a bolus injection in the Data window. 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental 
main window will open. 

 
2. Open the SAAM II Compartmental study file study_0_ExpInpUS. 
 

a. The file study_0_ExpInpUS.stu should appear in the file list; if it does not, 
find the folder where you put this file. 
 

b. In the File menu, click Open. The SAAM II Compartmental main window 
will appear as shown below: 

 
 

 
 

3. View the model and the experiment on the model. In the SAAM II Toolbox, 
click Experiment. The model of the experiment will appear on the Drawing 
Canvas as follows: 
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Notice the difference between this model and the experimental model developed 
and used in the Getting Started with Compartmental tutorial. Here there is no 
experimental input, ex1, and the sample circle, s1, is not filled because there are 
no data in the study file. 
 
You may wish to review the Parameters dialog box and the Samples Attributes 
dialog box. The parameters are those from study_0 except they have been fixed 
since this tutorial involves only simulations and no data fitting. The sample 
equation is “s1 = q1/vol”. 
 

4. Create a bolus injection into Compartment q1 where the amount of the bolus is 
specified in the Data window. 

 
a. In the SAAM II Toolbox, click Input. 
 
b. Click Compartment q1 and then click on the Drawing Canvas. The 

experimental input ex1 will appear associated with the model as shown below: 
 

 
 

c. Double-click ex1 to open the Exogenous Input dialog box. The Exogenous 
Input dialog box will appear as follows: 
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Notice in the Input Type pane, bolus is selected. 
 

d. Enter a bolus injection of “dose” specified by an equation. 
 

(1) In the Input Type pane, select Equation. 
 
(2) In the Equation box, type “ex1 = dose”. 
 
(3) In the Event Start box, type “0”. 
 
(4) In the Event Stop box, type “0”. 
 
(5) Click Add. The Exogenous Input dialog box will appear as follows: 
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 Specifying an equation as a bolus input. The effect of the above is the 
following. The equation is specified “ex1 = dose”. However, the start and stop 
times being equal to zero, specifies the bolus. The result will be a bolus dose 
at time zero equal to an amount “dose”. “dose” can either be entered as a 
parameter or in the Data window. 

 
 
 (6) Click Done. 

 
e. Enter the amount of the dose in the Data window. 
 

(1) In the Show menu, click Data, or alternatively, on the SAAM II Toolbar 

click Data   . The Data window will open as blank since there are no 
data associated with this study file. 

 
(2) In the Data window, type “CONST  dose  100”. The Data window will 

appear as follows: 
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 Specifying constants in the Data window. You can specify constants in the 
data window using the CONST designator. In this case CONST is used to 
define the constant “dose” equal to “100.” 

 
 
 (3) Close the Data window. 

 
5. Solve the model and view the solution. 
 

a. It will be useful to increase the resolution of your plot. In the Compute 
Menu, click Computational Settings. Type “200” in the Min. Nr. of 
Calculation Intervals box. Click Done. 

 
b. In the Compute menu, click Solve, or alternatively, on the SAAM II 

Toolbar, click Solve . 
 

c. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected so s1 is the only option in the 
Variables for Y-Axis pane. 
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d. Click s1 to add this to the Current Selection pane. The Plot and Table 
Variables dialog box will appear as shown below: 

 

 
 

e. Click Done. A plot of s1 will appear in semilog mode in the Plot window as 
shown below (if it is not in semilog mode, in the View menu, click Semilog): 
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f. Close the Plot window. 

 
Quit the SAAM II Compartmental application. Do not save the changes to 
study_0_ExpInp. 
 

 Specifying the amount of an input in the Data window using the Equation type 
of Exogenous Input. The above is an example of how to specify the amount 
of a bolus injection where the amount of the bolus is specified in the Data 
window. It is clear that multiple boluses, constant infusions, multiple constant 
infusions and primed infusions can be specified similarly. It is simply a matter 
of how the equation input is specified. Suppose, for example, you wanted to 
specify a primed constant infusion where the priming dose was 100 and the 
infusion rate was 25 for a specified time interval. If in the Data window, there 
were two constants entered, for example  

 
  CONST dose 100  
 
 and  
 
  CONST dose1 25 
 
 were entered, the Exogenous Input dialog box could look as follows: 
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Here the bolus is specified equal to “dose” since it starts and stops at time 
zero. It is followed by a constant infusion equal to “dose1” starting at time 0 
and ending at time 4. 
 
Thus the Equation input type gives you great flexibility in specifying inputs 
where information about the input can be contained in the data file. 
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Part 2. Dose as an adjustable parameter 
 
 It is not often that the amount of material in the dose can be an adjustable parameter. 
This is because, under normal circumstances, the volume of the pool into which the test 
substance is administered needs to be estimated. To obtain an estimate of this volume, it 
is necessary to know the dose precisely. 
 
There are instances, however, when the amount of the dose can be an adjustable 
parameter. Normally this occurs when one has a single input-multiple output 
experimental design. An example would be a bolus injection into plasma with plasma and 
urine samples. Another example would be if volume were precisely known. This is the 
example that will be illustrated in this part of the tutorial. 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental 
main window will open. 

 
2. Open the SAAM II Compartmental study file study_0. 

 
a. The file study_0.stu should appear in the file list; if it does not, find the folder 

where you put this file. 
 

b. In the File menu, click Open. The SAAM II Compartmental main window 
will appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, 
click Experiment. The model of the experiment will appear on the Drawing 
Canvas as follows: 

 

 
 
You may wish to review the Parameters dialog box and the Samples Attributes 
dialog box. The sample equation is “s1 = q1/vol”. 
 

4. Create a bolus injection into Compartment q1 where the amount of the dose is an 
unknown parameter. 

 
a. Double-click ex1 to open the Exogenous Input dialog box. The Exogenous 

Input dialog box will appear as follows: 
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This is the bolus input specified in study_0. It assumes the dose is known and 
the volume vol is unknown. In what follows, the situation will be reversed. 
The dose will be assumed unknown and the volume known. 
 

b. Click Delete to remove the bolus injection. 
 
c. Create the input. 
 

(1) In the Input Type pane, select Equation. 
 
(2) In the Equation box, type “ex1 = dose”. 
 
(3) Be sure the Event Start and Event Stop times are set equal to zero. 
 
(4) Click Add. The Exogenous Input dialog box will appear as follows: 
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(5) Click Done. 
 

The input now has been defined as an equation where the equation is a 
constant “dose”. “dose” will appear as a parameter when you open the 
Parameters dialog box. The event start and stop times being zero 
specifies the equation as a bolus. Since a new parameter has been 
introduced, a value for it must be specified in the Parameters dialog box.  

 
5. Specify the model parameters. 
 

a. In the Show menu, click Parameters, or alternatively, on the SAAM II 

Toolbar, click Parameters . The Parameters dialog box will open, as 
shown below: 
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You can see dose now appears as a parameter. If you specify a value for the 
dose and leave all the other parameters adjustable, you will not be able to fit 
the model to the data because there are too many parameter values. In this 
example, it will be assumed that the volume vol is known, and equal to 2000 
ml. 
 

b. Set the parameters are follows: 
 

(1) Double-click dose to select it. 
 
(2) In the Value box, type “1.0e+08”. 
 
(3) Click Save. 
 
(4) Double-click vol to select it. 
 
(5) Select Fixed as the Type. 
 
(6) Click Save. The Parameters dialog box will appear as follows: 
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(7) Click Done. 

 
6. Solve the model and view the solution. 
 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II 

Toolbar, click Solve . 
 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected so s1:plasma is the only 
option in the Variables for Y-Axis pane. 

 
c. Click s1:plasma to add this to the Current Selection pane. The Plot and 

Table Variables dialog box will appear as follows: 
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d. Click Done. A plot of s1 and plasma will appear in semilog mode in the Plot 

window as shown below (if it is not in semilog mode, in the View menu, click 
Semilog): 
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Leave the Plot window open. 
 

7. Fit the model to the data and view the solution. 
 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar, 

click Fit . Your plot will be updated as follows: 
 

 
 
b. In the Show menu, click Statistics, or alternatively, on the SAAM II 

Toolbar, click Statistics . The Statistics window will open as follows: 
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The model parameters are estimated with good precision. Notice, of course, 
vol is a fixed parameter. ex1.bolus appears as a derived parameter because of 
the specification of the input as an equation. 

 
c. Close the Statistics and Plot windows. 

 
Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 3. Split inputs (an input into more than one compartment) 
 
There may be occasion when your have an experimental input into more than one 
compartment, and you may not know how the input distributes among the compartments. 
One example is injecting radioiodinated low density lipoproteins (LDL) where the 
radioactive iodide distributes between two subpopulations of LDL particles. Another 
example would be an injected material with an unknown amount of contaminants where 
the material and contaminant have different kinetics. Thus what is known is the total 
amount of material administered; what may not be known is how it distributed. This 
situation is accommodated in SAAM II using the split input capability in the Exogenous 
Input dialog box. 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental 
main window will open. 

 
2. Create the following system model. 
 

 
Notice this is a two-compartment model where there is no interconnection 
between the two compartments; there is only a loss from each. 

 
3. Create the experiment on the model. 
 

a. In the SAAM II Toolbox, click Experiment. Notice that the Model tools are 
unavailable and the Experiment tools are available. The Experiment 
Attributes dialog box will open. 

 
b. Change the entry in the Units box from “minutes” to “days.” 
 
c. Type “9” in the End at box. The Experiment Attributes dialog box will 

appear as shown below: 
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d. Click Done. The Create Experiment dialog box will appear on the Drawing 
Canvas. The choice is to create an Experiment (Exper) or System 
experiment. The Exper experiment is selected as follows: 

 

 
 

e. Click Create (since Exper is selected, and this is the type of experiment you 
want to create). Your model will appear as follows: 

 

 
 

4. Add the data 
 
a. On the Show menu, click Data, or alternatively, on the SAAM II Toolbar, 

click Data . The Data window will open. 
 
b. On the File menu, click Open. The file study_0.dat should appear in the list 

(if it does not, find the folder where you put this data file). 
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c. Double-click study_0. The data in this file will appear in the Data window. 
The model and the Data window should appear with the model on the 
Drawing Canvas as follows: 

 

 
 
d. Close the Data window. 
 

5. Create the sample on the model. 
 

a. In the SAAM II Toolbox, click Sample. 
 
b. Click Compartment q1, then Compartment q2, and then click on the Drawing 

Canvas. 
 

A sample object, s1, will appear on the Drawing Canvas attached to 
Compartments q1 and q2. This means your sample was from plasma. Notice 
that the circle at the top of the sample object is an open circle; data have not 
yet been associated with the sample. The sample object can be moved on the 
Drawing Canvas to a location you desire. 
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c. Double-click s1 to open the Sample Attributes dialog box. 
 
d. Type “plasma” in the Associate with Data Name box.  
 
e. Edit the sample equation “s1 = q1+q2” to read “s1 = (q1+q2)/vol” in the 

Equations pane. The Sample Attributes dialog box will appear as follows: 
 

 
 

f. Click Done. The model will appear as follows: 
 

 
 
 

7. Create the experimental input 
 
a. In the SAAM II Toolbox, click Input. 
 
b. Click Compartment q1, then Compartment q2, and then click on the Drawing 

Canvas. 
 

An input arrow named ex1 will appear on the Drawing Canvas attached to 
Compartments q1 and q2. The input syringe can be moved to a desired 
location. The model will appear as follows: 
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c. Double-click ex1 to open the Exogenous Input dialog box. 
 

b. Type “1.04e+08” in the Initial Amount box. 
 
e. Click Add. The Exogenous Input dialog box should appear as follows: 
 

 
 

Notice the Split Input button is active. 
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 Split inputs. Split inputs occur when your injected test substance is not 
kinetically homogeneous, but kinetically heterogeneous. This means the input 
consists of two or more substances with different kinetics. This can be due to 
a variety of factors including contamination. It is important to be aware when 
this can happen, and incorporate it into your model. 

 
 
f. In the Exogenous Input dialog box, click Split Input. The Split Exogenous 

Input dialog box will open as follows: 
 

 
 

 Split Exogenous Input. When you have a split input, you know the total 
amount of substance given, but you may not know how the substance 
distributes among different compartments. You must write equations which 
relate the amounts in the different compartments to the total. In this example 
where the input is a bolus, ex1 is the total dose. The doses in Compartments 
q1 and q2 are respectively ex1.1 and ex1.2. 

 
 
g. In the Equation box in the Split Exogenous Input dialog box, edit the 

equations to read: 
 

ex1.1=frac*ex1 
ex1.2=(1-frac)*ex1 

 
The Split Exogenous Input dialog box together with the Exogenous Input 
dialog box will appear as follows: 
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 Split exogenous input. The above equations partition the total dose, ex1, into 
two fractions. frac will become a parameter whose value lies between 0 and 1. 
It will be the fraction of the total dose in Compartment q1. The value 1 – frac 
will be the total dose in Compartment q2. 

 
 

h. In the Split Exogenous Input dialog box, click Done. The Exogenous Input 
dialog box will remain as shown above. The only indication of the split input 
is the Split Input option is active. 
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i. In the Exogenous Input dialog box, click Done. 
 

8. Add parameter values to the model. 
 

a. In the Show menu, click Parameters, or alternatively, on the SAAM II 

Toolbar, click Parameters . The Parameters dialog box will open.  
 
b. Add the parameters as shown in the Parameters dialog box below: 
 

 
 

 Split exogenous input. In the above, frac is a parameter whose value lies 
between 0.1 and 0.9. Notice also there are four parameters to estimate, the two 
losses, the volume, and frac. 

 
 
c. Click Done. 
 

9. Solve the model, and view the solution. 
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a. In the Compute menu, click Solve, or alternatively, on the SAAM II 

Toolbar, click Solve . 
 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected so s1:plasma is the only 
option in the Variables for Y-Axis pane. 

 
c. Click s1:plasma to add this to the Current Selection pane. The Plot and 

Table Variables dialog box will appear as follows: 
 

 
 

 
d. Click Done. A plot of s1 and plasma will appear in semilog mode in the Plot 

window as shown below (if it is not in linear mode, in the View menu, click 
Semilog): 
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Leave the Plot window open. 
 

7. Fit the model to the data and view the solution. 
 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar, 

click Fit . Your plot will be updated as follows: 
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b. In the Show menu, click Statistics, or alternatively, on the SAAM II 

Toolbar, click Statistics . The Statistics window will open as follows: 
 

 
 

The model parameters are estimated with good precision. The value for frac is 
0.69 which means 69% of the original injected dose is into Compartment q1. 
Under Derived Variables, you can see the exact amount of dose in each 
compartment predicted by the model. 
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c. Close the Statistics and Plot windows. 

 
Quit the SAAM II Compartmental application. You may save the study file if you 
wish. 
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Part 4. Parametric deconvolution 
 

Deconvolution is the technique used to address the following problem. There is a 
known system and a known output from an unknown input. The problem is to 
calculate the unknown input. The problem is shown diagrammatically as follows: 

 

 
 

There are basically two ways to deal with this problem. One is called nonparametric 
deconvolution. This is an extremely difficult problem. The other is called parametric 
deconvolution. 
 
In parametric deconvolution, the following are assumed: 
 

• The exact specification of the system model (in terms of a compartmental 
model, this means the structure and all parameter values). 

• There are output data. 
• The specification of the input is known (in terms of the situation here, this 

means the equation for the input is known but the parameters of the equation 
are unknown and will be estimated from the data). 

 
This part of the tutorial will illustrate how to perform parametric deconvolution using 
SAAM II. 
 
1. Start the SAAM II Compartmental application. The SAAM II Compartmental 

main window will open as shown below: 
 
2. Open the SAAM II Compartmental study file study_0_ExpInp. 
 

a. The file study_0_ExpInp.stu should appear in the file list; if it does not, find 
the folder where you put this file. 
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b. In the File menu, click Open. The SAAM II Compartmental main window 
will appear. In the SAAM II Toolbox, click Experiment. The model of the 
experiment for study_0_ExpInp.stu will appear on the Drawing Canvas as 
follows: 

 

 
3. Enter and view the data. 
 

a. In the Show menu, click Data, or alternatively, on the SAAM II Toolbar, 

click Data . The Data window will open. 
 
b. In the File menu, click Open. The file paradecon_ExpInpUS.dat should 

appear in the list (if it does not, find the folder where you put this data file). 
 
c. Double-click paradecon_ExpInpUS.dat. The data in this file will appear in 

the Data window as follows: 
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These are simulated data obtained when an exponential input was specified 
and samples were created at the same time samples were taken in the data file 
study_0.dat. 
 

d. Close the Data window. 
 
e. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. 
 

f. Be sure the List All Variables check box is selected. (Click this box if it is 
not selected). 

 
g. Click plasma to move it to the Current Selection pane. 
 
h. Click Done. A plot of the data will appear in the Plot window. 
 
i. In the View menu, click Line Plot. 

 
j. In the View menu, be sure Semilog is selected. Your plot will appear as 

follows: 
 

 
 

These are the output data. The problem is to specify an input function format, 
and to estimate the parameters of this input from the data. 
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k. Close the Plot window.  
 

4. Associate the sample s1 with the plasma data. 
 

a. Double-click s1 to open the Sample Attributes dialog box. 
 
b. In the Associate with Data Name box, type “plasma”. The Sample 

Attributes dialog box will appear as follows: 
 

 
 
c. Click Done. 

 
5. Specify and define the input function. 
 

In this example, the input function is assumed to be known, and be equal to 
A*(exp(-a*t)-exp(-b*t)). This will be entered as equation input, and the 
parameters A, a and b estimated from the data. 
 
a. In the SAAM II Toolbox, click Input. 
 
b. Click on Compartment q1 and then the Drawing Canvas. The input ex1 will 

appear. 
 
c. Double-click ex1 to open the Exogenous Input dialog box. 
 
d. Specify the equation input. 
 

(1) In the Input Type pane, select Equation 
 
(2) In the Equation box, type “ex1=A*(exp(-a*t)-exp(-b*t))”. 
 
(3) In the Event Start box, type “0”. 
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(4) In the Event Stop box, type “9”. (Remember the time of the experiment in 
study_0 is 9 days). Click Add. The Exogenous Input dialog box will 
appear as follows: 

 

 
 
(5) Click Done. 

 
6. Specify the parameter values. 
 
a. In the Show menu, click Parameters, or alternatively, on the SAAM II Toolbar, 

click Parameters . The Parameters dialog box will open, as shown below: 
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The model parameters are all present and fixed. These are the k(i,j) and vol. In 
parametric deconvolution, the model parameters are assumed to be known 
precisely, and hence must be fixed. 
 
The unknown model parameters are those characterizing the input function. In 
parametric deconvolution, the “type” of input function is assumed to be 
known but the parameters of the function are unknown. In this case, these 
parameters are A, a and b. 

 
b. Enter the parameter values. 
 

(1) If A is not selected, double-click A to select it. Type “100” in the Value 
box, and click Save. 

 
(2) Double-click a to select it. Type “0.05” in the Value box, and click Save. 
 
(3) Double-click b to select it. Type “0.5” in the Value box, and click Save. 

The Parameters dialog box will appear as follows: 
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(4) Click Done. 
 

7. Solve the model and view the solution. 
 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II 

Toolbar, click Solve . 
 
b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . The Plot and Table Variables dialog box will open. Be sure 
the List All Variables check box is not selected. 

 
c. Click s1:plasma to move this to the Current Selection pane. Your plot will 

appear as shown below (in linear mode). 
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Leave the Plot window open. 
 

8. Fit the model to the data and view the results. 
 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar 

click Fit . The plot will be updated as follows: 
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 Close the Plot window. 
 
b. In the Show menu, click Statistics, or alternatively, on the SAAM II 

Toolbar, click Statistics . The Statistics window will open as follows: 
 

 
 
 Close the Statistics window. 
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9. View the unknown input function. 

 
a. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, 

click Plot . Your previous plot should open. 
 
b. In the Set menu, click Plot/Table Variables. The Plot and Table Variables 

dialog box will open. Be sure the List All Variables check box is selected. 
 
c. Click ex1.infusion to move this to the Current Selection pane. The Plot and 

Table Variables dialog box will appear as follows: 
 

 
 
d. Click Done. The plot of the unknown input function will appear as follows 

(the plot is in linear mode, and the Y Axis maximum has been set equal to 
80): 

 

Rev. 10/30/05 ExpInpUS-41 2002 - 2005 University of Washington 



Using SAAM II Working with Experimental Inputs 

Rev. 10/30/05 ExpInpUS-42 2002 - 2005 University of Washington 

 
 
e.  Close the Plot window. 
 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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